现在的位置: 首页 > PHP开发 > 正文
win7下使用wamp server 2.1中使用PHP5.3配置Zend guard loader的问题
2013年10月29日 PHP开发 ⁄ 共 636字 暂无评论 ⁄ 被围观 3,075 views+

win7下使用wamp server 2.1中使用PHP5.3配置Zend guard loader,无法生效

wamp  Server换新版本了,使用PHP 5.3,原本有程序使用Zend  optimizer。更新到PHP5.3,需使用新版的Zend guard  loader(我这里不是安装版的,下载的是dll扩展)。

配置文件如下:(路径没有问题,也参考了官方的readme,xdebug的配置是在zend loader配置的下方)

[Zend.loader]

zend_extension="D:\wamp\bin\php\php5.3.3\ext\ZendLoader.dll"

zend_loader.enable=1

zend_loader.disable_licensing=0

zend_loader.obfuscation_level_support=3

zend_loader.license_path=

配置后运行wamp时弹出“丢失php5.dll”的错误,wamp上面显示的PHP扩展中 Zend Loader已经打上勾号,但是查看phpinfo上并没有,当然程序打开以后是乱码。

从 http://forums.zend.com/viewtopic.php?f=57&t=27748 找到了问题的解决方法:wamp中所带的PHP5.3是VC9 x86 Thread Safe版的,将wamp的PHP5.3换成VC9 x86 Non Thread Safe版的即可。

给我留言

您必须 [ 登录 ] 才能发表留言!